Minneapolis/Northrop Campus Internet Outage
Incident Report for The Blake School
Resolved
This incident has been resolved.
Posted Feb 03, 2025 - 17:56 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 03, 2025 - 15:31 CST
This incident affected: Northrop Campus Connectivity - Minneapolis.